You are not logged in.

Dear visitor, welcome to viecode.com. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

organix

Beginner

(10)

  • "organix" is male
  • "organix" started this thread

Posts: 6

Location: Karlsruhe

Occupation: IT Mensch

Reputation modifier: 1

  • Send private message

1

Tuesday, March 20th 2012, 5:12pm

Lexicon SEO Url Rewriting

Hallo,

ich habe heute das Lexikon Plugin erworben, weil ich damit in meiner Community eine Wissensdatenbank aufziehen möchte.
Ob ich mit meiner Anfrage hier im Unterforum zu "SecuritySystem basic" richtig bin weiß ich als neuer User noch nicht, ich konnte aber kein Supportforum für Lexicon finden. Aber um das geht es mir jetzt gar nicht.

Ich kämpfe ein wenig mit den SEO URL Rewriting Optionen von Lexikon.
Ich nutze auf meinem Board (www.neotrax.de) schon URL Rewriting (mod_rewrite), beispielsweise für die Foren und Beiträge. Auch die Startseite habe ich mittels einer eigenen Umschreibung im ACP auf das Portal umgelenkt. Das funktioniert auch alles soweit. Für das Lexikon Plugin will das aber nicht funktionieren.
Ich schalte im ACP / Optionen / Suchmaschinenoptimierung /Link-Umschreibung die Umschreibungen für Lexikon ein, was ím übrigen auch direkt nach der Installation schon so voreingestellt war. Da noch kein Content in meinem Lexikon ist, kann ich es noch nicht sehr weit testen.
Aber beispielsweise die erste Option, "Lexikon-Übersicht-Verweise umschreiben" stelle ich auf den Standardwert "{LEXICON_APPLICATION}/", damit wird die Startseite für das Plugin im Hauptmenü bei mir auf www.neotrax.de/lexicon/ umgeschrieben. Das endet dann aber in einem Fehler 404 Site not found.
Und ein Blick in die .htaccess zeigt mir auch nicht eine einzige Rewrite Regel für Lexikon an. Die Rewrite Regeln für das Forum, eigene Umschreibungen sind in der .htaccess enthalten und wenn ich im ACP Änderungen diesbezüglich vornehme, dann wird auch brav die .htaccess entsprechend aktualisiert. Aber für die im ACP gemachten SEO Einträge für Lexikon wird nicht eine einzige Regel geschrieben.

Hier mal meine .htaccess mit aktivierten Umschreiberegeln für Lexikon:



Source code

1
2
3
4
# WCF-SEO-STARTRewriteEngine OnRewriteBase /
# custom rewrite rulesRewriteRule ^/?$ index.php?page=Portal [L,QSA]
RewriteRule ^tag/([0-9]+)-([^/\.]*)/?$ index.php?page=TaggedObjects&tagID=$1 [L,QSA]
RewriteRule ^([^/\.]+)/([0-9]+)-([^/\.]*)/last-post\.html$ index.php?page=Thread&threadID=$2&action=lastPost [L,QSA]RewriteRule ^([^/\.]+)/([0-9]+)-([^/\.]*)/first-new-post\.html$ index.php?page=Thread&threadID=$2&action=firstNew [L,QSA]RewriteRule ^([^/\.]+)/p([0-9]+)-([^/\.]*)/?$ index.php?page=Thread&postID=$2 [L,QSA]RewriteRule ^([^/\.]+)/([0-9]+)-([^/\.]*)/index([0-9]+)\.html$ index.php?page=Thread&threadID=$2&pageNo=$4 [L,QSA]RewriteRule ^([^/\.]+)/([0-9]+)-([^/\.]*)/?$ index.php?page=Thread&threadID=$2 [L,QSA]RewriteRule ^([^/\.]+)/board([0-9]+)\.html$ index.php?page=Board&boardTitle=$1&pageNo=$2 [L,QSA]RewriteRule ^([^/\.]+)\.html$ index.php?page=Board&boardTitle=$1 [L,QSA]# WCF-SEO-END



Mich wundert, dass hier weit und breit von Lexikon kein Eintrag dabei ist.
Somit dürfte dann auch die Frage soweit formuliert sein. Was ist zu tun, damit das funktioniert. Sind irgendwelche eigene Umschreibungen notwendig. Ich konnte leider weder hier im Forum noch in den Anleitungen im Lexikon hier nichts finden. Ein Manual zum Plugin gibt es ja wohl auch keines, zumindest kann ich bislang keines finden.


Gruß
Markus
Music for motion pictures, www.neoterra.de

This post has been edited 1 times, last edit by "organix" (Mar 20th 2012, 7:27pm)


bastchen

Beginner

(10)

Posts: 8

Reputation modifier: 3

  • Send private message

Peter

Administrator

(1,496)

  • "Peter" is male

Posts: 14,379

Reputation modifier: 34

  • Send private message

3

Wednesday, March 21st 2012, 12:40am

Schalte dich bitte für die Supportforen frei: https://www.viecode.com/support/pluginstore/activation.html
Dort gibt es u.a. eine Problemlösung: [Anwendungsfehler] Häufige Anwendungsfehler im Lexikon 4.0.x

Similar threads

Rate this thread
Support
Forum
Spotlight

Kunden, die unsere Produkte über den WoltLab Plugin-Store erworben haben, können sich nun über unsere Aktivierungsseite für die Supportbereiche freischalten.

Applications